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Copyright Notice 

Copyright © by BrightBox Software Pty. Ltd. ABN: 29 139 371 752. All rights reserved.  

No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into 

any language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, manual or otherwise, 

without prior permission of BrightBox Software. 

Disclaimer 

Except for the limited warranty described in the software license agreement, Brighbox Software Pty. Ltd. makes no 

representation or warranties with respect to the contents hereof and specifically disclaims any implied warranties of 

merchantability or fitness for any particular purpose. No dealer, company or person is authorised to expand or alter our 

warranties or this disclaimer. Any such representation will not bind Brightbox Software Pty. Ltd.  

Brightbox Software Pty. Ltd. reserves the right to revise this publication and to make changes from time to time in the 

content hereof without obligation of Brightbox Software Pty. Ltd. to notify any person of such changes. 

Trademarks 

Microsoft Excel is a trademark of the Microsoft Corporation. AutoCAD is a trademark of the AutoDesk Corporation. 

Any references made or implied to other products have been made to help describe functions used in the software. 

Every effort has been made to supply complete and accurate information. However, Brightbox Software Pty. Ltd. 

assumes no responsibility for its use, nor any infringements of patent or other rights of third parties which would 

result.  
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1. Introduction 
MudShark is the next generation earthworks estimating software that is simple enough for anyone to use; you can be 

productive within minutes of your first use. This guide compliments MudShark's simple and flexible user interactions 

helping you move from beginner to expert in very little time. 

The content of this guide has been designed so it can be read from cover to cover or skip to individual sections of 

interest. However it may be easier to follow some of this document if you load up the sample Project.  

To open the Sample project from your installation: 

• Click the Project tab in the ribbon. 

• Click Import Project… 

• In the Import Project window navigate to “Program Files\BrightBox\MudShark\Samples” or if you are using 

the 32 bit application on a 64 bit system “Program Files (x86)\BrightBox\MudShark\Samples”. 

• Select HillTopHouse.bbx  

• Click Open. 

 
Figure 1. MudShark interactive 3D visualisation 
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After reading this guide you will be able to: 

• Understand how MudShark works. 

• Confidently use our fully interactive 3D Viewport. 

• Manage your Projects and Plans. 

• Take Off complex Working Areas, Contours, Spot Elevations and Structures quickly and accurately. 

• Manipulate and reuse Materials and their Factors. 

• Calculate and understand the Results. 

• Trace where Materials originated from and has ended up. 

• Calculate how much Material is being removed from the site or brought in from off Site. 

• Produce stunning graphical images of your 3D Site. 

• Produce detailed reports of Stripping, Cut, Fill, Respread and Structure Volumes. 
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2. How MudShark Works 
Unlike most other cut and fill software MudShark uses Solid Modelling to calculate results for your Project. This means 

it is capable of producing much more accurate volume results with a richer visual display. In order to generate these 

results MudShark needs to build a 4D model of how the Site currently looks (Existing Site) and how the Site will 

eventually look (Proposed Site). These models are constructed using the Smart 3D Take Off tools to digitise the sites as 

they are represented in Plans. 

Take Off the elevations of the land with Contours and Spot Elevations, as well as denoting Structures that need to be 

demolished or built. MudShark will use this information to construct 4D models of both site stages (which you can 

view) and calculate what needs to happen to the Existing Site to produce the Final Site. From these Strata Operations 

MudShark creates solid 3D Entities, these in combination with Material and reuse factors are used to calculate the 

Results which get displayed in 3D in the Viewport pane and in a grid in the Results pane. 

Workflow 

MudShark is made to fit into your existing workflow and 

there are few rules or restrictions on the order that you 

calculate your Project. However a suggested workflow of 

how you could work through your Project is: 

1) Insert Plans 

• Insert, Align and Scale the Plan(s) that are required 

for the Project. 

2) Site Take Off 

• Enter the Project's Working Area. 

• Enter each Site Stages surface elevations using Contours and/or Spot Elevations. 

• Nominate the boundaries and Materials of Structures as required. 

3) Calculate Results 

• Configure Ground Settings. 

• Calculate Results. 

• Navigate and validate 3D results. 

• Navigate and validate the results grid. 

• Export results. 

Figure 2. Suggested MudShark workflow 
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3. User Interface 
MudShark’s intuitive interface is designed to help you easily navigate the software and to complete your Project 

efficiently with a minimal learning curve. Modern user interface design components have been used allowing flexibility 

in how you interact with your interface. 

 
Figure 3. Main user interface components in MudShark. 

Pane Interaction  

MudShark panes are windows that you can have continuously open, allowing you greater efficiency and flexibility with 

how you work. 

You can change the position and size of your Panes. Panes can be in one of three states: 

• Docked to the edge of MudShark. 

• Embedded in the centre workspace area. 

• Floating anywhere on your screen(s). 

If a Pane you want to work with is not visible on your screen on the View tab in the Show Panes group you can click 

on the control that corresponds to the pane you want to see. And whether the pane has been closed, hidden, obscured 

or unpinned it will be shown to you in its last visible state. 
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Docked Panes can be Pinned so that they remain visible or Unpinned so they collapse to the edge of the screen. To 

change the Pinned state, click the Pin button in 

a docked panes title bar. 

To make an Embedded pane Docked to a screen 

edge: 

• Click with the right mouse button on the 

embedded panes tab. A context menu 

appears. 

• Click Dockable. 

To dock a floating pane or change the location of an already docked pane: 

• Click and hold in the title bar of the pane. 

• Drag the pane to the Docking Overlay control that represents the direction you want to dock the pane. 

• Hover over the side you want to dock the pane to a live preview of how the pane will be docked is displayed.  

• Release the mouse button to dock the pane. 

 
Figure 5.Docking Overlay controls appear when you drag panes around the screen to allow you to dock and embed them.  

Figure 4. Clicking on an Embedded panes tab with the right mouse 
button. 
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List Panes 

These panes contain a list of the items that can be made visible 

in the Viewport. They provide a means of viewing and 

modifying what you have entered into the Project. 

• Plan List pane contains all the Plans (and their layers) that 

have been inserted into the Project. 

• Take Off List pane contains all the Take Off Entities that have 

been added into the Project arranged into Containers 

grouped by the Site Stage they belong to. 

• 3D Site List contains all the 3D Entities that have been 

calculated from the Take Off for the Site arranged into 

Containers grouped by the Site Stage they are associated 

with.  

Change Visibility 

With Plans, Take Off and 3D Entities your Viewport can appear 

cluttered. You can clear up your view and focus clearly on your 

current task by changing the visibility of items within a List 

pane. Some of this is handled automatically when you change 

the View Mode. However if you want to override the default 

behaviour you can choose to show or hide any Item. 

Each item in a list contains a check box to the left of the item. This is the items visibility check box. If the item is visible 

there will be a checkmark inside this box. To change the visibility of an item select or clear the check box making the 

item visible or invisible respectively. 

Note: You can still change the properties of items that are invisible. 

Changing the visibility of a Container (An Item that can have sub-Items) will also update the visibility of its sub-Items. 

So you can quickly adjust the visibility no matter how many Entities you are interacting with; showing/hiding an entire 

Site Stage with a single click of the mouse button. 

Selection 

Items in the List panes can be selected by clicking on their names. When an Item is selected in a list it is also shown as 

selected in the Viewport. 

If the item has children then all of its child items will be selected and highlighted in the Viewport. So you can select all 

Structures at once or select them one at a time. 

Figure 6. Take Off List pane with multiple Items 
visible in the Viewport. 
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If a single item is selected then, where applicable, you will be able to edit information about that item in the Properties 

pane. When you first create an item it will be selected by default so you will be able to edit its properties if you need to 

as efficiently as possible. 

Deletion 

Select the Entities that you want to delete then press the Delete key on your keyboard. If you delete something by 

mistake you can undo the deletion. 

Some entries in the List panes cannot be deleted and will instead delete all the items that are the children of it. For 

example if you want to delete all Contours in the Existing Site stage you could Select the Contours item then Delete it. 

Each Contour in the Site Stage will be removed but the Contours container will remain. 

Expansion 

Some items in the list can be expanded by clicking on the arrow next to the item this will toggle the Item showing as 

expanded or collapsed. This can allow you to drill down to the smallest piece of information or collapse to a higher 

level to use a broad overview of your Project. 

Viewport Pane 

The Viewport is a view of the currently visible Items 

in all the List panes. This is where you perform Take 

Off from a Plan and view your 3D Site results. 

For more Information see 5. Using the Viewport. 

Properties Pane 

The Properties pane shows information about the 

current Project wide Entity selection. If a single item 

is selected then you will be able to edit information 

about that Item. If there is more than 1 Item selected 

then the Properties pane will contain a list of the 

number and type of Entities selected. 

Most List pane Containers can also be edited in the 

Properties pane. If you want to change the colour of 

the Existing Site Stage Contours you can select the Contours item then choose a new colour. All Contours that are 

already a part of that group will have their colour updated. 

Figure 7 Properties pane showing information about the 
currently selected Entities. 
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Results Pane 

This pane allows you to explore tabular views of your Results data that can then be exported to XLS or XML file 

readable by third party applications such as Microsoft Excel. 

Boring Log Pane 

Define the default materials that make up the ground on your site either as single list thicknesses or a complex array of 

multiple soil borings.  

Project Details Pane 

Contains information about your Project which is useful when choosing a Project to open. Additionally this is where 

you can configure a number of Ground Settings which affect the calculation Results. 
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4. Viewport Modes 
Where it will increase the efficiency of performing your tasks, such as scaling Plans and performing Take Off, 

MudShark has utilised modes which apply to interacting with the Viewport. That is the current mode MudShark is in 

controls how the Viewport will respond to your interactions. 

In many other programs excessive use of modes can easily lead to confusion. MudShark keeps you constantly informed 

about the current mode of the Viewport in the: 

• Ribbon: the current mode indicators will be highlighted in the Home tab. 

• Task Panel: the current mode is displayed as the title. 

 
Figure 8. Active Modes are highlighted in the ribbon. 

View Mode 

The Viewport in MudShark has 2 View Modes: 

• Take Off mode is made for accurate Take Off. 

• 3D Site changes the camera to use perspective to give a more natural looking 3D experience. 

Note: In the image of the ribbon above. Take Off is the currently active View Mode. 

Each View Mode remembers the visibility of all of your Items. If you reactivate a View Mode it will set all Items to have 

the same visibility they had when that View Mode was last used. 

Active Site Stage 

When performing Take Off MudShark uses the Active Site Stage to know where to insert the Entities. This can either 

be Existing Site or the Proposed Site. 

The Active Site Stage in Figure 8 is the Existing Site which means that the next Contour that is drawn will be added to 

the Existing Site. To change the Active Site Stage to the Proposed Site click Proposed Site in the Take Off group on the 

Home tab. 



  

Copyright © 2019. BrightBox Software  15 

 

Take Off Task 

For each Take Off Entity you draw in MudShark you must first indicate what type of Entity you are taking off. The Task 

defines the type of Take Off Entity created. You can only have one active Take Off Task at any given time and each 

task has different Tools that they can use. For example you can Take Off Contours with the Polyline or Transmute 

Tools but not with the Point Tool. 

 
Figure 9. Current Take Off Task is adding Contours to the Existing Site. 

Tools 

Tools control how the Viewport responds to interaction. There are many tools in MudShark including: 

• Draw Entities in the Viewport. 

• Select Entities in the Viewport. 

• Scale Plans. 

• Moving the camera in the Viewport. 

While a Tool is active its corresponding button is highlighted in the Ribbon or in the Viewport Toolbar. 

Some Tools are designed to be a Single Use Tool. That is once you have performed a single action with that Tool the 

previously active Tool is again activated. This is useful for Tools that are generally only going to be used once and are 

complementary to your main goal. 

For example if you are drawing Contours with the Polyline tool and you want to use the Zoom Rectangle to zoom in closer to 

an area of the Plan it is likely that you will only be using the Zoom Rectangle once. After the zoom is completed MudShark will 

reactivate the Polyline tool. 

Some Tools are Multi Use Tools. That is once you start using that Tool it stays active until you deactivate it or choose 

to use another Tool. Tools where you are likely to want to repeatedly perform the same action are usually going to be 

Multi Use Tools. 

For example when Taking Off Contours you will usually be drawing more than 1 Contour to have to click in the Ribbon to start 

drawing a new Contour each time would be inefficient. As such the Polyline Tool stays active until you activate another Tool. 
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5. Using the Viewport 
Most of the work you do in MudShark will be inside your Viewport. To maximise your efficiency with MudShark we 

recommend getting accustomed with how to move the camera around, draw, select and edit entities in the Viewport. 

 
Figure 10. The Viewport displaying a Project with the Working Area and Contours for the Existing Site Stage entered. 

The main areas in the Viewport pane are: 

• Workspace - The area of the Viewport dedicated to the Visual display. 

• Viewport Toolbar - Provides quick access to commonly used Tools to navigate around the Viewport Workspace. 

• Task Panel - Provides contextual text about the current Task as well as helpful editors when performing Take Off or 

other Viewport related Tasks. To find out more about using the Task Panel refer to Tasks within the 8. Take Off section 

of this document. 
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Navigating 

The most efficient means of navigating around the Viewport is directly interacting with the Viewport Workspace using 

the mouse and keyboard.  

A number of Viewport Tools require that the Viewport Workspace is active (has focus) before using them. The 

Viewport is activated when it is clicked in. To activate the Viewport to perform an operation that doesn’t involve 

clicking (for example using the scroll wheel to zoom) we recommend that you click the right mouse button inside the 

Viewport Workspace. 

Pan 

 

To move the camera left, right, up and down you need to Pan it. The quickest way mid takeoff is to use your mouse: 

• Click and hold the mouse wheel button in the Viewport. 

• Moving the pointer in the direction you want to Pan. 

Note: You can also Pan with your keyboard. Press and hold one or more direction keys in the direction you want to Pan when 

the Viewport is active. 

Rotate 

 

To get a view of your Site from a different angle you can rotate the camera: 

• Hold down the Ctrl key. 

• Click and hold the mouse wheel button in the Viewport. 

• Moving the pointer will rotate the current view. 

Zoom 

 

Moves the camera in closer or further away, to change the Zoom in your Viewport: 

• Activate the Viewport. 

• Rotate the mouse wheel. 
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Zoom Fit 

 

Click Zoom Fit in the Viewport Toolbar and the camera will zoom so that all the currently visible Entities fit the 

Viewport. This is a great way to return to an overall view of your Site.  

Zoom Selected 

 

Click Zoom Selected in the Viewport Toolbar and the camera will zoom so that all the currently selected Entities fit the 

Viewport. 

Zoom Window 

 

If you need to Zoom to a particular area of your Site: 

•  Click Zoom Window in the Viewport Toolbar. 

•  Drag a rectangular area in the Viewport Workspace. 

The Viewport will then zoom in as tight as possible on that rectangle. 

 Top Down 

 

To move the camera to get a bird’s eye view of your Site in either 3D Site or Take Off View Modes click Top Down in 

the Viewport Toolbar. 

Selection 

The Select tool enables you to select only the Take Off Entities that you have drawn and the 3D Site Entities that have 

been generated to calculate the cut and fill. 

 
Figure 11. The Select tool active for the entire Site. 
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To enter Selection mode click Select in the Edit group on the Home tab. 

You can then click on an Entity in the Viewport to Select it. If the Viewport can select the Entity it will be highlighted 

and selected in the other Panes in the application. 

Multiple Selection 

You can use the Select tool to select multiple Entities at a time. 

You can select a rectangular area of Entities by clicking and dragging a rectangle around the items you want to select. 

Any selectable Entity that crosses or is contained within the rectangular area will be selected. 

Alternatively you can hold down the Ctrl Key and Click on the individual Entities you want to select. 

Tip: To select all selectable Entities visible in the Viewport press Ctrl + A while the Select tool is active. 

Drawing 

To ensure the most accurate Take Off all drawing Tools are only usable in the Take Off View Mode. If you make any 

mistakes while drawing you can undo what you have done by Clicking Undo in the Quick Access Toolbar. Alternatively 

you can delete what you have drawn by Selecting the Entity and then pressing Delete. 

Polyline Tool 

 
Figure 12. The Contours Polyline tool active for the Existing Site Stage. 

A polyline is a continuous entity that is made up of one or more straight lines or arcs. To draw a polyline ensure 

Polyline is active in the Tool group on the Home tab. 

Drawing Straight Lines 

Straight lines in a polyline are drawn by clicking on the points of the shape you are drawing. If you are tracing a Plan 

that has vector data you can hold down the SHIFT key to snap to a Point. 

Drawing Arcs 

Drawing arcs has been streamlined with an intuitive drag operation into the normal takeoff procedure so that you can 

complete your takeoff as quickly as possible. 

• Click the start point. 
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• Click and hold the left mouse button on the end point. 

• Drag the line until it becomes an arc. You will see an overlay showing where the circular arc will be drawn. 

• Release the mouse button when the arc is at the desired dimensions. 

• You can now draw another arc, straight line or finalise the polyline. 

Note: MudShark arcs are circular, if you are unable to get the arc to fit perfectly you can split a single large arc up into smaller 

segments.  

Finishing a Polyline 

MudShark uses Smart 3D Take Off tools when drawing so what you are drawing will influence how you can finish 

drawing a Polyline. 

Right click will execute the default finalising operation for the type of entity you are drawing. If that entity is required 

to be a closed shape (e.g. A Boundary) the shape will automatically try and form a closed shape. If you are Taking Off a 

free form entity such as a Contour that doesn’t have to be closed the right click will just end editing and will not try and 

form a closed shape. 

If you want to close a shape you can explicitly do so by clicking on the start point of that shape. 

Tip: Ctrl + J is the keyboard shortcut for closing a Polyline by joining the end point of a polyline to the start point. 

Note: If you right click and the Polyline is not valid for the type of Entity (e.g. a single point for a Contour) then 

MudShark treats this like cancelled input. 

Point 

 
Figure 13. The Spot Elevations tool active for the Existing Site Stage. 

Clicking Point in the Tools group on the Home tab will activate point drawing. 

Points are entered by moving the mouse over the Viewport and clicking where you want to insert the Point.  

Transmute 

Transmute allows you to pick a Plan Entity and if the Plan Entity is compatible with the Active Take Off Task create a 

new Take Off Entity based off it.  

To Transmute a Plan Entity: 

•  Click the Transmute tool in the Tool group on the Home tab. 

•  Select the Altitude Source in the Task panel. 
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• Click on the Plan Entity you want to use in the viewport. 

This interaction is the same as the interaction for Select. Like the Select tool you can Transmute multiple entities at a 

time by drawing a rectangular area. All Plan Entities that cross or are found within that area will be transmuted.  

Tip: You can transmute all the Entities on a layer or in a plan by clicking on the Plan or Layer name in the Plan List pane when 

the Transmute tool is active.  

 
Figure 14. Transmuting a group of Entities. 

Tip: When Transmute is active you can Transmute all visible Entities in the Viewport by making the Viewport active and then 

pressing Ctrl + A. Make sure that only the Entities that you want to Take Off are visible and that none of these Entities cross 

each other. 
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6. Projects 
A Project contains all of your work that you do relating to an individual Site. You can have multiple Projects but only 1 

open at a time within MudShark. When MudShark is launched it immediately presents itself ready for the next project. 

Tip: If you want to view 2 Projects side by side you can open another instance of MudShark and open that Project. 

It is important when working in MudShark to regularly save the changes you make to your Project. To ensure that you 

don't lose any data we recommend regularly backing up your Data Folder and Database. 

Opening a Project 

To open a Project that you have already worked on: 

• Click the Project tab. 

• Click Open. 

• This will display a list of all the Projects that you can open including their details. 

• In the Open Project window click on the Project you want to open. 

• Click the Open button. 

 
Figure 15. The Open Project window allows you locate and open your Projects quickly. 

  

Filter Project Details 

To find projects that meet certain criteria you can enter a filter value in the filter row. You can filter based on one or 

more columns and any Projects that don’t match the value you are searching for are hidden. Many different types of 
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filters can be combined so that no matter how many Projects you are searching through you will be able to find the 

Project that you need. 

To filter based on more than 1 value for a particular column you can click on (Custom) in the filter value box. This will 

show the Custom Filter window which will enable you to build up complex criteria for a single column. 

 
Figure 16. Custom Filter window allows you to define complex filters on a column in the Open Project window. 

To clear the search value for a column you can click on the Clear Filter Criteria button next to the value or clear all 

filter criteria for the row by clicking on the Clear All Filter Criteria button in the row header. 

Creating a New Project 

You can start work on a New Project at any time: 

• Click the Project tab. 

• Click New. 

While there are no required fields you must put in for a Project it is recommended that you give the Project a name 

that will help you identify it should you ever need to Open at a later time. You can enter a Name for your Project in the 

Project tab inside the Project Details pane. 
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Creating a Copy of a Project 

If you want to base a new Project on an existing Project or explore site balancing options you can Create a Copy of the 

currently opened Project: 

• Click the Project tab 

• Click Create a Copy… 

• In the Create a Copy window enter a Name for the new Project. 

• Click Create a Copy 

 

A copy will be created. If you want to work on the copy now you have to open the copy of the Project. You can do this 

as you would normally open an existing Project or by clicking on the Copy Created notification that is displayed when 

the copy is created (see Figure 18). 

 

 
Figure 17. Create a Copy of the currently opened Project. 

 

 
Figure 18. Open the copy of the Project by clicking on this notification. 

Moving Projects 

You may need to transfer Projects to other machines or send a Project to someone else. To share your Project you 

need to Export it to a BBX file which can then be imported into MudShark on another machine. 

Exporting Projects 
• Open the Project you want to Export. 

• Click the Project tab. 



  

Copyright © 2019. BrightBox Software  25 

 

• Click Export. 

• Click Project. 

• Choose where you want the file to be exported to. 

• In the File name box, type a name for the file, and then click Save. 

When the Export is complete MudShark will notify you with an alert in the bottom right hand corner of your screen. 

Tip: To quickly open the folder a file has been exported to; click on the alert that MudShark shows you when the export has 

completed. 

Importing Projects 

If you receive a BBX file from another user or want to restore an older version of a Project: 

• Click the Project tab. 

• Click Import Project. 

• Choose the file you want to Import. 

• Click Open. 
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7. Plans 
MudShark has been designed from the ground up to maximise efficiency when dealing with digital plans. 

MudShark can read DWG, DXF, PDF, BMP, PNG, JPG files as well as other common image formats. 

Regardless of the type of file you are using in your project before any Take Off is undertaken it is imperative that you 

ensure that all of your plans are correctly aligned and scaled so that all Take Off is correct. 

 
Figure 19. The Plan tab provides the tools needed to set up Plans for Take Off. 

Insert Plan 

 

To use a Plan inside a Project you need to Insert it: 

• Click Insert Plan on the Plans tab. 

• In the Open window select one or more files that you want to insert as Plans into your Project. 

• Click Open to confirm your selection. 

 
Figure 20. Open window allows you browse to the location of the Plans. 
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Tip: You can drag any number of valid Plan files into MudShark and the Plan(s) will be inserted into the current Project. 

Once a Plan is inserted into your Project it can be seen in the Plan List pane. 

You can use this Pane to: 

• Change the visibility of Plans or their layers by clicking in the check box to the left of the Plan name. 

• Select Plans or their layers by clicking on the names 

 
Figure 21. The Plan List pane shows you a list of all the loaded Plans and their layers. 

Note: For PDF files with multiple pages a Plan will be inserted for each page of the file. 

Aligning 

If you are calculating a Project that contains multiple Plans you need to ensure that those plans are correctly aligned so 

that the Take Off and subsequent cut and fill calculations are correct. An example of this would be where one Plan is 

provided for the Existing Site and another for the Proposed Site. 
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Rotate 

Some Plans are inserted in such a way as to make reading the information on them difficult. To aid in this you can 

rotate your Plans in 90 degree increments: 

• Select the Plan(s) you want to rotate in the Plan List by clicking on their names. 

• Click Rotate Left or Rotate Right in the Alignment group on the Plans tab. 

If you get your Plans and they are rotated at different angles you can use the Custom Rotate button. 

• Select the Plan(s) you want to rotate in the Plan List by clicking on their names. 

• Click Custom Rotate in the Alignment group on the Plans tab. 

• In degrees enter the Rotation angle to indicate by how much you want to rotate the selected Plan(s). 

• Click the direction button to rotate the Plan(s) either left or right by the Rotation angle. 

• You can rotate the selected Plan(s) as many times as you need until they are aligned correctly.  

• Click OK. 

 
Figure 22 Custom rotate selected Plans by the Rotation angle. 

 

Move 

If data points on Plans don’t align you can move your Plans so that all their data points are perfectly aligned: 

• Click on the name of the Plan you want to move in the Plan List pane. 

• Click Move in the Alignment group on the Plans tab. 

• Click on the reference point of the Plan that you want to move. 

• Click where you want to move that reference point to. 

Note: You can select more than 1 Plan to move at a time. 
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Scaling 

Before scaling Plans it is recommended that you ensure they are properly aligned. You can Scale each 

of your Plans separately or if you want to save time you can Scale multiple Plans at the same time 

using the same scaling line. 

 

To Scale your Plans: 

• Select the Plan(s) you want to Scale in the Plan List pane by 

clicking on their names. 

• Click Scale in the Scaling group on the Plans tab. 

• Choose a line on the plan that you know the length of. The 

longer the line is on screen the more accurate the scaling will 

be. 

• Click the mouse button at the first point on the line. 

• Click the mouse button at the last point on the line. 

• The Scale Plan(s) window will appear. 

• Enter the length of the line. 

• Click Scale to scale the current selection. 

Clear Scaling 

If you make a mistake while scaling a Plan you can rescale the Plan or Undo the scaling operation. However if you 

prefer you can clear all the scaling from the Plan and start from scratch. 

 

To Clear Scaling from Plans: 

• Select the Plans you want to Clear Scaling from in the Plan List pane by clicking on their names. 

• Click Clear in the Scaling group on the Plans tab. 

Figure 23. Scale Plan(s) window allows you to type in 
the length of the scale line. 
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8. Take Off 
Take Off for a Project refers to the process and resultant Entities of transferring the information from a Plan into your 

Model. Take Off is drawn in the Viewport Workspace using the drawing Tools. Created Take Off is inserted into the 

correct container in the Take Off List pane depending upon the Viewport Mode at the time of Take Off. This 

information is then used to generate a 3D Model which is used to calculate results. 

Working Area 

In order to perform calculations MudShark needs to know the boundaries which define the limits of excavation work. 

That is the area of your Site you want to calculate results for. 

You can draw Working Area Boundaries that represent an Include area (where work will be taking place) and also 

Exclude areas that are areas where there will be no work. This is useful if there are Existing Structures or areas that 

you don’t want to excavate within the main area of work such as a pond. You can draw as many boundaries nested 

inside each other as required and MudShark automatically works out if they are Include or Exclude Boundaries for you. 

 
Figure 24. Define the areas in your Project where work takes place. 

In order to generate any results MudShark needs at a minimum 1 outermost Include Boundary which denotes an area 

where Work is to happen. An outermost Boundary is a Boundary that is not enclosed in any other Boundaries. Unlike 

most takeoff systems you can have as many separate areas of excavation in a Project as you require and there are no 

limits to the number of outermost Include Boundaries that a project can have. This allows you to keep all of your 

Projects work in a single Project, instead of spread out over multiple Projects. 
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Unlike all other Take Off, when taking off Working Area it doesn't matter which Site Stage is the Active Site Stage, all 

Working Areas are added to the Project. 

 
Figure 25. Ribbon configured to Add Working Area Boundaries to the Project. 

To draw a Working Area Boundary: 

• Click Working Area in the Take Off group on the Home tab. 

• Trace the points for the Projects Working Area Boundary in the Viewport pane. 

• When you have clicked on all the points of the shape click the right mouse button and the Boundary will close. 

Boring 

 
Figure 26 Site generated with multiple borings 

A Boring represents a soil sample at a given location on a construction site. Multiple borings aid in modelling the initial 

ground strata from which excavation is undertaken and returning more accurate results.. They contain ordered layers 

of Materials specifying the thickness of each material. MudShark uses these values to calculate the volumes of each 

Material.  

Figure 27 Ribbon configured to Add Borings to the Project. 

 



  

Copyright © 2019. BrightBox Software  32 

 

Create a new Boring 

Borings can be entered one at a time from Plans or alternatively enter all the details of the Borings upfront in the 

Boring Log pane then plot these details in the Viewport. Details of all your Borings for a Project can be found in the 

Boring Log pane, alternatively you can browse the Borings in the Take Off pane and edit the details of each in the 

Property pane. 

New Borings in the Viewport 

• Click the Boring tool in the Take Off group of the Home tab. 

• Click on the Boring point in the Viewport.  

• In the Boring Point window enter a Name, Altitude and Note for the new Boring.  

• Define the Boring data see Defining Materials for a Boring 

• Click OK 

 
Figure 28. Boring Point window about to add B-2 boring. 

 

New Borings in the Boring Log Pane 

• Click on the Boring Log pane 

• In the Boring Log grid click in the Name cell of the Insert new Boring row. 

• Type the identifying Name, Altitude and Note for the Boring. 

• Define the Borings Materials see Defining Materials for a Boring 

• To add more Borings click on the new Insert new Boring  row or click on the Add… Boring button at the 

bottom of the grid. 

• Repeat for all of your Borings 
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Figure 29 Changing values in the Insert New Boring row will create an unplotted Boring. 

Plotting an Existing Boring 

Creating Borings in the Boring log can be more efficient and less 

prone to entering incorrect numbers. However you will need to plot 

the Boring that you have created in the Viewport. That is position it 

in the Viewport.  

• Click the Boring tool in the Take Off group of the Home 

tab. 

• Click on the Boring point in the Viewport.  

• From the Name list select the Boring that you want to 

position.  

• Check the Boring information is correct.  

If you misposition a Boring point you can always move it by selecting 

the Boring and using the Move Selection tool. 

Defining Materials for a Boring 

Each Boring point uses the same list of Materials which 

defines the order that Materials appear in the ground. This 

list can be defined in the Boring Log pane in the Materials in 

Ground list or alternatively entered on the fly in the Boring 

Point window when plotting Borings.  

Changing the Materials that are used in the ground can 

affect Borings that are already entered. For example 

deleting a Material out of the Materials in Ground list will 

remove that Material from all existing Borings.  

Once the ordered Material list is created you can enter in thicknesses and Notes for each Boring segment. If a Boring 

doesn’t contain a Material enter a value of Zero. MudShark can handle Stratum that do not cover your entire site. 

Figure 30. Select the Name of the Boring  Point 
you want to plot. 

Figure 31. The Silty layer is set to 0 as it doesn't occur in this 
Boring. 



  

Copyright © 2019. BrightBox Software  34 

 

Note: If you are using average depths for Materials over a site you can just define the Materials in Ground and the 

calculation will work off the default thicknesses provided.  

Contours 

A Contour line represents a geographical entity where each point on the line is at the same altitude and is frequently 

used to indicate topography of the Site. 

You can Take Off Contours for both the Existing and Proposed Site. It is important to ensure the Site you want to add 

the Contour to is the active Site before you begin Take Off. 

 
Figure 32. Contours are being Taken Off. 

Tracing 

While generally it is quicker to Transmute your Contours not all Plans lend themselves to efficient Transmuting. In 

these scenarios you can trace your Contours into the Viewport Workspace using the Task Panel to efficiently enter the 

Contours altitudes. 

Next altitude: the altitude that will be assigned to the next Contour that you draw. 

Increment is the difference in altitude between the Contours you are drawing. Usually you will only have to enter this 

value once per Project. After you have completed your next Contour this increment will be applied to the value in the 

Next altitude box. 

Direction indicates that current direction of the slope you are taking off. That is are you taking off Contours that are 

increasing in elevation, remaining flat or decreasing in elevation. This control makes it very easy to Take Off sites with 

an undulating surface as you don’t need to keep typing in new Altitudes instead simply changing the Direction of the 

Take Off. Once you have added your first Contour changing the direction will change the value of the Next altitude. 

 
Figure 33. The Task panel sets the altitude of the next Contour. 

Tip: If there is vector data on the plan you can snap to the nearest point by holding down the Shift key when moving the 

mouse over an active viewport. 
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Transmute 

The quickest way to Take Off Contours is by Transmuting. This is only available when you are Taking Off from a Plan 

that comes from a vector file. 

Instead of tracing the Contours on a Plan, Transmuting allows you to pick lines on the Plan that represent Contours. 

The interaction works the same way as the Select tool except you are only able to select Plan Entities. MudShark will 

then trace a Contour over that line in the Plan. 

Tip: Like the Select tool you can select a group of Entities by dragging a rectangle around the Entities to Transmute. 

The altitude of the new Contour that is created is determined by the Altitude source in the Task Panel. 

 
Figure 34. Transmuting Plan Entities into Contours using the altitudes in the Plan. 

Plan as the Altitude source means that the altitude used when creating the Contour will come from the Plan. Some 

vector files have 3D data in them where the Contours have been created at the correct height. Where this is the case 

this is the most efficient option for taking off these Contours. While using the Plan as the source the Next altitude, 

Increment and Direction controls are not needed and are unavailable. 

Custom as the Altitude source means that the altitude will be defined the same as a Contour that is traced in with the 

Polyline tool. That is the next Contour that is transmuted will be assigned the altitude in the Next altitude box. The 

Increment and Direction boxes are available when using the Custom Altitude source. 

To Transmute a Contour: 

• Click on the Existing Site or Proposed Site in the Take Off group on the Home tab to activate the correct Site. 

• Click Contours in the Take Off group on the Home tab. 

• Click Transmute in the Tools group on the Home tab. 

• Select the Altitude source that you want to use for Transmuting. If you click the Custom enter values for the Next 

altitude and Increment boxes. 

• Click on the line in the Viewport from the Plan you want to use. 

Tip: When Transmute is active you can Transmute all visible Entities in the Viewport by making the Viewport active and then 

pressing Ctrl + A. Make sure that only the Entities that you want to Take Off are visible and that none of these Entities cross 

each other. 

Spot Elevations 

To Take Off elevations at a single point in either the Existing Site or Proposed Site use Spot Elevations. 
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Figure 35. The Next altitude will be assigned to the next Spot Elevation that is input. 

To input a Spot Elevation: 

• Click on the Existing Site or Proposed Site in the Take Off group on the Home tab to activate the correct Site. 

• Click Spot Elevations in the Take Off group on the Home tab. 

• Click Point in the Tools group. 

• In the Task Panel type the Next altitude. 

• Click in the Viewport where you want the Spot Elevation created. 

By eliminating the need to navigate or have windows popping up and obstructing your view we have been able to 

greatly increases the speed and accuracy with which you can input multiple points into the Viewport. 

Inputting multiple Spot Elevations: 

• After creating your first Spot Elevation and while the Viewport Workspace has focus. 

• Type the altitude of the next Spot Elevation. 

• MudShark inserts the altitude in the Next altitude box in the Task Panel. 

• Click in the Viewport where you want the Spot Elevation created. 

Structures 

In MudShark a Structure is any item on a Site that is being demolished or built. Structures are entered by Taking Off 

each Structures Boundaries and entering in each Structures Material Layers. Each Site Stage can have as many 

Structures as required. 

 
Figure 36. The Demolished Structures menu allows you to edit Structures or create a New Structure. 

Demolished Structure 

A Structure that needs to be removed from the Site is called a Demolished Structure and should be created in the 

Existing Site Stage. For example if a Site requires the removal of a driveway. 
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Built Structure 

A Structure that is being added to the Site as part of the works is called a Built Structure and should be created in the 

Proposed Site Stage. For example if a site requires laying down a foundation slab. 

Unchanged Structures 

Structures that already exist and aren’t being changed as part of the works should be Taken Off as an Excluded 

Working Area. 

For example if there is a building that is being extended and it falls inside the Working Area of Excavation that 

Structure should be taken off as an Excluded Working Area Boundary. 

For more information on Taking Off Working Area Boundaries please refer to Working Area section at the start of this 

chapter. 

Create a New Structure 

Before you can Take Off a Structures Boundaries you need to Create a New Structure: 

• Click on the Existing Site or Proposed Site in the Take Off group on the Home tab to activate the correct Site. 

• Click New Structure in the Take Off group on the Home tab. 

• The New Structure window will appear. 

• Enter information about your Structure. For more information about entering Materials see Structure Materials section. 

• Click Create. 

 
Figure 37. The New Structure window allows you to define properties of the Structure before adding it to the active Site. 
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Once you have added a Structure it will be added to the drop down underneath the Structures tool. This list of 

Structures is filtered based on the currently Active Site Stage. 

 
Figure 38. Ready to Take Off Boundaries for the School Structure that will be demolished. 

You are now able to start Taking Off your new Structures Boundaries.  

Taking Off Structure Boundaries 

Drawing a Structures Boundaries is similar to drawing the 

Boundaries of the Working Area. You can define the Area 

that makes up a Structure by tracing Include Boundaries 

that define the area that the Structure includes and 

Exclude Boundaries whose areas are removed from the 

Structure. Allowing complex Structure shapes to be input 

quickly and intuitively. 

You can add as many top level Include Boundaries as you 

want for a single Structure. If you have 3 building pads that are made up of the same Materials you can Take Off all the 

building pads as a Single Structure. This means you only need to enter in the Materials for that Structure once and all 

the results will be grouped together. 

To add Boundaries to a Structure you must first activate the Structure that you want to draw Boundaries for: 

• Click on the Existing Site or Proposed Site in the Take Off group on the Home tab to activate the Site that contains the 

Structure you want to add Boundaries for. 

• On the Home tab in the Take Off group click the drop down section of the New Structure control. 

• Click the name of the Structure you want to add Boundaries for. If the Structure does not exist you can create a New 

Structure. 

While a Structure is active any Take Off you draw will be added as a Boundary to that Structure. 

Note: MudShark will automatically recalculate the appropriate Respread and Stripping areas in real time as you are Taking Off 

the Structures Boundaries. 

Point Altitudes 

Unlike a Working Area Boundary each point on a Structure 

Boundary is input at a specific altitude. 

Figure 39. New Structures can be created from the Structures 
menu. 
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The value in the Next altitude box in the Task Panel corresponds to the altitude that the next point of the Structure 

will be assigned. 

Note: When a Structure Boundary is joined to form a closed 

shape the value in the Next Altitude box is ignored and the 

altitude of the first point is applied to the last point. 

To edit the altitudes of a Structure Boundary: 

• Select the Structure Boundary in the Take Off List pane. 

• Click Point Altitudes in the Properties pane. 

• Click on the Altitude you want to change. Once a cell is 

selected the point you are about to change is 

highlighted in the Viewport. 

• Type the new altitude for the point in the cell. 

  

Figure 40. The altitude applied to the next point on the 
current Structure Boundary. 

Figure 41. Structure Boundary Property pane showing the 
altitude of each point in a Structure Boundary. 
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Structure Materials 

You can define the Materials that make up your Structures and 

this will give you more accurate results for the Cut and Fill across 

the site as well as volumes for the Structures themselves. 

This information can be defined in the New Structure window or 

edited at a later time by: 

• Select the Structure you want to edit in the Take Off List 

pane. 

• Click Ground Layers in the Properties pane. 

• Change the Materials as required. 

The order that the Materials are displayed is the order they 

appear in the Structure working from the top surface of the 

structure down. 

Note: For more information about adding Materials into your Project 

see the Materials section. 

  

Figure 42. The Materials that make up a Structure can 
be edited in the Structures Property pane. 
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Stripping and Respread 

In most other cut and fill programs you are required to enter the Stripping and Respread areas manually which can 

involve retracing the Working Area and Structure boundaries again. To save you time MudShark calculates the areas 

for Stripping and Respread automatically based on the Take Off that you have already completed. 

You can view the Take Off for the Stripping and Respread at any time as the boundaries are updated in real-time as 

you complete your Take Off and can be found in the Take Off List pane under the Stripping and Respread container 

items. 

To calculate your Stripping and Respread values you need to enter a thickness for each. This can be done in the Project 

Details pane under the Ground Settings tab or in the Properties pane when either the Stripping or Respread item is 

selected. 

With the inclusion of Multiple Borings you can now specify stripping by the layer or layers of soil you want to strip 

rather than by thickness.  

To specify Stripping by layer: 

• Click the Project Details pane. 

• Click the Ground Settings tab. 

• Click Strip away and select the last layer of soil 

you want to strip away. This will strip any 

Material higher in the list as well as the 

Material that you choose to remove. 

Tip: You can strip away more than 1 Layer. For example 

if you have three layers in your strata Organic Matter; Topsoil and Subsoil you can strip away both Organic Matter and 

Topsoil by clicking to strip away Topsoil. This will strip all Topsoil and any layers above topsoil.  

 
Figure 44. 3D Site view of the Proposed Site Stage with Respread selected. 

Figure 43. Click Strip  away to remove 1 or more soil layers 
before cut and fill calculations. 
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Editing 

Once you have finished drawing the Take Off you are able to the change properties of that Take Off. The usual way to 

do that is to select the Take Off Entity in the Take Off List pane and then edit the properties in the Properties pane. 

Editing your Take Off is a good way of balancing your site and some time spent exploring options for your site can save 

you or your clients a large amount of money.  

Adjusting Altitude 

Sometimes you may need to adjust the Altitude of a few points in your Take Off Entity. You may want to move the 

Altitude of all your Structure points higher or lower to adjust the overall Site Balance. Or perhaps you made a mistake 

and accidentally put an entire 50 point Structure in at an Altitude of 1m instead of 5m. 

In these cases the standard method of editing Altitudes one at 

a time in different Properties pane controls can be tedious 

and time consuming. Rather than do this you can: 

• Select all the Take Off which contains points you want to 

Adjust from the Take Off List pane. 

• Click Adjust Altitudes in the Edit group on the Home tab. 

• The Adjust Altitude window will be shown. 

• Clicking on Relative adjustment or Absolute value. 

• Enter a value in the correct box. 

• Click OK. 

Relative adjustment will increase or decrease the altitude of 

all the selected Take Off points by the value in the box. A 

positive number will increase the Altitude of the selected points while a negative value will decrease the Altitude of the 

selected points. 

Absolute value will set the Altitude of each selected Take Off point to the value in the Absolute value box. If you make 

a mistake all changes made in the Adjust Altitude window are undoable. 

Move Selection 

You can change the location of takeoff items on a site in either Take Off or 3D view. This visual movement allows you 

to quickly change where items such as structures will be located on a site. The interaction for moving takeoff is similar 

to moving a plan: 

• Select the takeoff you want moved in the Take Off List pane by clicking on the name(s) of the takeoff. In 

Figure 38 two structures are selected to be moved. 

• Click Move Selection in the Edit group on the Home tab. 

• In the viewport click on a reference point of what you want to move. 

Figure 45. Change the altitude of multiple Take Off Entities 
simultaneously with the Adjust Altitude window. 
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• In the viewport click where you want to move that reference point to.  

 
Figure 46: Select takeoff to move in the Take Off List pane. 
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9. Materials 
In MudShark all 3D Entities that are created are made up of 1 or more Materials. Each Material has a number of 

different properties which control how it looks as well as affecting how the Material behaves when subjected to Cut 

and Fill operations. 

Global Materials 

If you have Materials that you repeatedly use you can add them into the Global Materials List. These Materials can 

then be easily used in your Projects without the tedious repetition of typing in the same values all the time. 

To access the Global Materials list click on Global Materials in the Materials group in the Home tab. 

The List comes prepopulated with a number of Materials each organised into a Category. Once a Material is used in a 

project it is copied into your Project List, changes made to the Global list will not affect any of your existing Projects. 

 
Figure 47. A central collection of all predefined Materials. 

Project Materials 

Once you use a Material inside your Project it will be added to the Project Materials List which is accessible under the 

Home tab by clicking Project Materials in the Materials group. 

Each Material property that you change on this screen is updated everywhere in the Project where that Material is 

used. No changes in this window will update any values in the Global Material List. 
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Figure 48. All Materials that have been used in the current Project. 

Tip: Selecting a Material in the Project Materials window will highlight that Material in the Viewport, if its use is currently 

visible. 

Factors 

Each Material has 2 Factors that adjust how their volumes react to being removed or added to the ground or structure. 

If you don’t know these values for your current Project that is alright however the more accurate the information you 

have the more accurate the result and reuse calculations will be. 

Bulking Factor 

When Material is moved out of the ground it will typically swell up to occupy a larger volume. You can use the Bulking 

Factor to indicate the extent of this Bulking. 

For example a Bulking Factor of 2.00 will result in a Material that when it is Cut from the soil will double in volume. 

Compression Factor 

When Material is added to the ground, as is the case when performing a Fill Strata Operation, the Material will often 

settle or shrink to be a smaller volume. However in some cases it will end up occupying a large volume. Use the 

Compression Factor to adjust how the Material behaves in this circumstance. 

If you are importing Material from offsite then the Compression Factor will be directly applied to that volume such that a 

Compression Factor of 0.5 will mean the imported material will halve in volume when it is put into the ground. 
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If you are reusing Material that has been taken out of the ground the Bulking Factor is first applied in reverse to the Bulked 

volume to arrive at the Banked Volume and then the Compression Factor is applied to that to calculate the Compressed 

Volume. If the Materials Bulking Factor is 2 and it’s Compression Factor is 0.5 the reused Material will be half of the Banked 

Volume and 0.25 of the Bulked Volume. 

Using Materials 

Two Materials are added into a Project by 

default. That is the Respread Material and 

the Fill Material both of which denote the 

properties of Material that may need to be 

imported into the Site. Changes made to the 

Respread Material can affect the Imported 

Respread Result figures, likewise, changes to 

the Fill Material can affect the Imported Fill 

Volumes. 

Note: The default values for both the Respread 

Material and Fill Material can be changed in 

the Options window. These changes will take 

effect on the next new Project. 

Elsewhere you can either create new 

Materials or pick from Materials that already exist in either the Global Material list or the Project Material list. 

Materials are generally added through a Material Grid as shown in Figure 41. 

To insert a Material: 

• Click in the cell of the Material Grid where you want to insert the Material. 

• Type the name of the Material. 

• If the Material name doesn’t already exist a new Material will be created and added to the Project Materials list. 

• If the name of the Material does exist then the currently selected Material in the drop down will be used. With a 

reference to the Material added to the Project list. 

Tip: If you prefer you can browse the existing Materials by clicking on the drop down arrow in the Material column cell where 

you are inserting the Material. 

Note: You can delete a Material from where it is being used by clicking on the row selector in the Material grid and pressing 

the Delete key. 

Figure 49. Selecting Materials from the Global and Project List to be 
inserted into a Material grid. 
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10. Results 
Ground Setup 

The final results are greatly affected by a number of parameters such as the initial state of the Existing Site Strata as 

well as the thickness of Stripping and Respread and how much reuse is estimated to occur between Strata Operations. 

These settings can be accessed in either the Boring Log pane or the Ground Settings tab of the Project Details pane.  

More information on Stripping and Respread settings can be found in the Stripping and Respread section of the Take 

Off  chapter. 

 
Figure 50. The Ground Settings contain information about how calculations will be carried out. 

Initial Ground Strata 

The Materials in Ground and the Boring Log grids define the 

Material that make up each of the Stratum in the Existing Site 

Stage. With the order they appear in the grid representing the 

order they appear in the ground. That is the Material in the 

first row of the grid represents the Material just below the 

surface. 

If no Stratum are entered for the Initial Ground Strata then a 

default Stratum comprising the default Existing Soil Material 

will be created. This Stratum will have a thickness 

automatically calculated for it. 

More information on how to enter Multiple Boring information 

is available in the Boring section of the Take Off chapter.  

Figure 51. Materials in the ground can be defined in the 
Boring Log pane. 
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Material Reuse 

Sometimes when performing Cut Strata Operations a proportion of the soil you are taking out won’t be available for 

reuse either because it is not suitable or because during the process some of the Material will be wasted. To cater for 

this scenario you can define the percentage of Material removed from the ground which is then available for reuse as 

Fill or Respread. 

Stripping Reuse is the percentage of Stripping volume that will be available for reuse as Respread. 

Cut Reuse is the percentage of Cut volume that will be available for reuse as Fill. 

Calculating Results 

MudShark can calculate Results for the following: 

• Stripping Area and volumes. 

• Cut Volumes in Open Ground and beneath Structures. 

• Fill Volumes in Open Ground and beneath Structures. 

• Respread Area and volumes. 

• Structure Material volumes. 

• Material Reuse. 

• Site Balance volumes. 

You can wait until you have finished all your Take Off before calculating your results however if you do not have all the 

information available you are still able to get an accurate estimate based on the data you currently have. 

To calculate results MudShark requires at least: 

• 1 Include Working Area Boundary 

• 1 Elevation Entity (Contour or Spot Elevation) in the Existing Site stage. 

Once you have this information entered for your Site you can calculate the results at any time by clicking Calculate in 

the Results group. The more Site data you have entered the longer it will take for calculation to complete, but you will 

have far more accurate results. 

If you make changes to your Take Off, Material factors or other information which can affect results, recalculation will 

be necessary. 

After the results are calculated you are able to verify and explore the results in the fully interactive 3D Viewport as 

well as getting a detailed breakdown of all the results in the Results pane.  
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Navigating Visual 3D Results 

We recommend that you validate all results that MudShark calculates and a visual validation is quite often the quickest 

way to achieving that. After Calculation there should be no gaps between 3D Site Entities in the Viewport. The 

Viewport provides the perfect medium for visual verification as you can freely navigate around your entire Site or 

isolate areas of interest. 

When exploring the results in 3D we recommend switching the View Mode to 3D Site as this changes the camera to 

use perspective to give the Viewport a deeper feel. This is available on the Home tab. 

After clicking on 3D Site in the View Mode group by default the Existing Site Stage is displayed as it appears before 

any Strata Operations. You can expand the items in the 3D Site List pane changing the selection or visibility of any 

items so that you can visualise and concentrate on the parts of the Site that are important to you. 

 
Figure 52. 3D Site view of the Proposed Site Stage with Structure Fill selected. 

Once you have finished viewing the Existing Site Stage you can switch to the Proposed Site Stage by clicking Proposed 

Site in the Take Off group on the Home tab. Alternatively you can manually change the selection using the checkboxes 

in the 3D Site List pane. 

Note: If you then click Existing Site while in 3D the visibility that was last active when you were viewing the 3D Site will 

be restored. Likewise if you switch back to Take Off View Mode the visibility of items that was on during your last Take 

Off will be restored. 

Note: Any view in the Viewport can be exported as either an image or a 3D vector file. For more information see 

Exporting Results. 
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Edge Style 

You can alter the visual style that the 3D entities are displayed with; increasing or reducing the contrast of the 3D 

entities in the Viewport. 

 
Figure 53. The View tab offers three Edge Styles for your 3D Entities. 

• Sharp Edges are highlighted with a black line. 

• Opaque Edges are highlighted with a colour derived from the colour of the Entity. 

• Smooth Edges are not highlighted. 

Calculation Troubleshooting 

Occasionally when you attempt to calculate results for your site you will be informed that your site could not calculate 

or the 3D results will look wrong.  

 

You may have traced or transmuted contours that cross each 

other. This is usually the case when transmuting from a file that 

contains errors. MudShark can highlight crossing contours for 

you: 

• Click on Check Contours 

• Any crossing Contours will be highlighted in red in the Viewport 

pane. 

• Correct the highlighted Contours.  

• Click Calculate again.  

 

 

If you have a site that has a large hole in it or appears much thicker than it should you may have entered the structure 

at an incorrect altitude.  

Figure 54 Check Contours can highlight errors in 
contours 
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Results Grid 

All the Volume results are collated, filtered and grouped into task oriented sections and are accessible to you in the 

Results pane where the Solid Model, Material Factors and reuse calculations are applied to present a grid of results. 

This view gives you a more detailed breakdown of the results than you would get if you were looking at the Viewport 

in isolation. 

What Information is Available 

The Results pane allows you quickly see the Total Cut Bulked Volume for a single Strata Operation, a single Material or 

the Entire Site. And of that, how much Exported Bulked Volume needs to be taken off Site and how much is Reused in 

other places on the Site. 

Furthermore you can see the total compressed volume for the Fill and a breakdown of how much of that was reused 

From Site versus what will need to be Imported from off Site. 

This information is them summarised as a Bulked Site Balance. This shows which items have a net effect of requiring 

Materials to be removed from the Site or brought in from somewhere else. A negative number indicates a net effect of 

Material being removed from the Site. You can then use the Site Balance values to adjust your earthwork plans to try 

and achieve the optimal material reuse. 

 
Figure 55. Results can be grouped by Strata Operation and Materials then expanded or collapsed to display exactly what you 

want to see. 
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Filters 

There are a number of built-in filters that you can apply to your Result data. These comprise 2 predetermined 

groupings: 

Strata Operation groups the data by the Strata Operation that affects them (e.g. All Stripping under a single group). 

This allows you to easily see volumes that relate to each Operation regardless of what type of Material it is made up of. 

Material groups all the results by the type of Material they are so that you can better see how much of each Material is 

being used and where it is being used on the Site. 

For each grouping you are able to drill down into ever finer detail that shows where the result has come from. 

Moreover you can filter these groups so that you are only able to see volume results from Structures, the Ground or 

both. 

 
Figure 56. The results can be highlighted and audited in a 3D View. 

Tip: Selecting items in the results grid will highlight them in the Viewport to help associate and identify the relationship 

between the 3D Site and the Results. 
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Exporting Results 

Both your visual and tabular results have been designed so that they can be reused in your workflow with powerful 

exporting to commonly used external file formats. 

 

  

Figure 57. Project tab allows you to Export your results. 
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Microsoft Excel 

To Export all the results shown in the Results pane into a format that is easily shared and reusable: 

• Click the Project tab. 

• Click Export. 

• Click the All Results. 

The Excel file is created so that a separate tab is defined for each different result filter. Additionally the data is 

formatted in such a way that you can interact with the data groups in a similar way that you would in MudShark will 

expandable and collapsible group; so that you are able work with only the data that you need. 

 
Figure 58. A comprehensive Microsoft Excel workbook is produced with multiple sheets by Strata Operation and Materials. 

Tip: If you do not have Microsoft Excel a number of different programs exist that can read data from these files including 

many Estimating systems. 
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Viewport Snapshot 

The currently framed visible entities in the Viewport can be exported as an image file for your records or for reuse in 

third party applications. You can take as many snap shots as you need (from any angle) and you can turn on any 

Entities from your Plans, Take Off or 3D Site to capture in an image. 

When taking a snapshot we recommend putting MudShark in the same View Mode as the type of data you are 

capturing. That is Take Off mode for an accurate top down look onto the Sites Take Off and 3D Site for any view 

where you want to see perspective on your entities. 

To Export a Viewport Snapshot: 

• Click the Project tab. 

• Click Export. 

• Click the Viewport Snapshot. 

• In the File Name box type a name for the file. 

• From the Save as Type box select the type of image you want to create. 

• Click Save. 

 
Figure 59. A Viewport snapshot can be taken from any angle with all Entities that are visible within the frame of the Viewport. 
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Export 3D Vector Data 

All currently visible Entities in the Viewport can be exported to a 3D vector file for use in other applications. To export 

different views of your data you change the visibility of your Entities to suit. These files can then be reused in Take Off 

on other applications; integrated into your BIM workflow or used for 3D printing. 

 
Figure 60. Exported 3D vector data can be put to use in 3rd party software applications. 

To Export the Visible Site: 

• Click the Project tab. 

• Click Export. 

• Click Visible Site. 

• In the File Name box, type a name for the file. 

• From the Save as Type box select the type of file you want to create. To create a file for 3D Printing click 3D Print STL. 

• Click Save. 
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Appendix A. Keyboard and Mouse Shortcuts 
General 

Key Meaning 

Delete Delete current selection. 

Ctrl+S Save the current Project. 

Ctrl+O Open a Project. 

Ctrl+N Create a New Project. 

Ctrl + Shift + N  Create a New Structure. 

Ctrl+Z Undo. 

Ctrl+Y Redo. 

Ctrl+C Copy text from a control. 

Ctrl+V Paste text into an editable control. 

Ctrl+ right arrow Move the insertion point to the beginning of the next word. 

Ctrl + left arrow Move the insertion point to the beginning of the previous word. 

Ctrl+Tab Cycle through pane windows. 

Ctrl+F4 Close the active pane if that pane can be closed. 

Ctrl + 1 Show Plan List pane. 

Ctrl + 2 Show Take Off List pane. 

Ctrl + 3 Show 3D Site List pane. 

Ctrl + 4 Show Properties pane. 
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Ctrl + 5 Show Project Details pane. 

Ctrl + 6 Show Viewport pane. 

Ctrl + 7 Show Results pane. 

Viewport 
Key Meaning 

Ctrl+A When Select or Transmute are active will perform the operation on all visible 

Entities in the Viewport. 

Delete Delete current selection 

Arrow keys Pan the Viewport Workspace in the direction indicated. 

Ctrl + 0 Perform Zoom Fit on Viewport. 

Ctrl + J  Joins the end point to the start point when Taking Off. 

Rotate the mouse wheel Changes the zoom used in the viewport. 

Click the mouse wheel 

button and drag 

Pans the viewport. 

Ctrl + click the mouse 

wheel button and drag 

Rotates the viewport. 

 List Panes 
Key Meaning 

Asterisk (*) on numeric 

keypad 

Display all sub-Items under the selected Item. 

Plus sign (+) on numeric 

keypad 

Display the sub-Items directly under the selected item 
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Minus sign (-) on numeric 

keypad 

Collapse the Items directly under the selected Item group. 

Left arrow Collapse the current selection (if it is expanded) and move focus to the group 

leaf root. 

Right arrow Display the sub-items directly under the selected Item (if it is collapsed). 

Ctrl+Up arrow Scroll the list without changing the selection. 

Ctrl+Down arrow Scroll the list without changing the selection. 

Any printable key or keys Moves the selection to the Item matching the prefix letters in the beginning 

of the label. 
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Appendix B. System Requirements 
Software 

Recommended Operating System: Windows 10 (64 bit) 

Supported Operating Systems: Windows 7/8/8.1/10/Vista & Windows Server 2003/2008 

Required Software: NET Framework 4 & SQL Server Express 2005 SP2 or later. 

 

Hardware 

For best results,  we recommend using a 2 button mouse, with a scroll wheel. For activation, and deactivation, an active 

internet connection is also required. 

 

  Minimum Recommended 

Intel Processer  

(or AMD equivalent) 
I5 2.6 GHz I7 2.6 GHz 

Memory 8+ GB Ram 8+ GB Ram 

Graphics Card 

1 GB Ram 

Open GL 2.0 or higher compatible 

card with up to date drivers 

2 GB Ram 

Open GL 2.0 or higher compatible 

card with up to date drivers 

Hard Drive Space 1 GB free space 1 GB free space 

  

  

 



  

Copyright © 2019. BrightBox Software  61 

 

Glossary 
3 

3D Site 
Three dimensional visualisation of existing/proposed site and the results. 

A 

Active Site/Active Site Stage 
The Site Stage that is currently being worked on. Newly added Take Off will be added to the active site stage. 

Application Menu 
The menu that is displayed when you click the Project tab. The application menu contains common tools for creating, 

saving, and publishing a Project. 

B 

Banked Volume 
Is the volume of material in its natural state, e.g. in the ground before work is undertaken or when it is brought on site. 

BBX 
Mudshark file extension for an exported project. 

Boring 
The thicknesses of the soil in the initial ground at a given point.  

Boring Segment 
An individual definition of a Material and it’s thickness inside a Boring.  

Boundary 
A Boundary that defines an area where work will be carried out. 

Built Structure 
A new Structure entity on the Proposed Site. 

Bulked Volume 
The total volume of earth that has been extracted from the ground to which the bulking factor has been applied. 
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Bulking Factor 
The factor at which the material expands when removed from the ground. The factor used is based on the banked or 

natural state of the material. 

C 

Compressed Volume 
The total volume of earth that has been added to the ground to which the compression factor has been applied. 

Compression Factor 
The factor by which the Material will settle/shrink when added to the ground. The factor used is based on the banked or 

natural state of the Material. 

Container 
An item in a list pane that contains or can contain Items. 

Contour 
A line on a Plan which has an altitude value. 

Cut 
The volume of material needed to be excavated from the site. 

Cut Reuse Percentage 
The percentage of cut Material that can be reused as Fill. 

Cut Volume 
The volume of Material excavated from the Site. 

D 

Demolished Structure 
A Structure Entity that has to be removed from the existing Site. 

Dock 
Describes the function when a window is positioned left/right/top or bottom of the screen. 

DWG 
DWG ("drawing") is a binary file format used for storing two and three dimensional design data and metadata. 

DXF 
Drawing Exchange Format. A file format that enables the exchange of drawings between AutoCAD and other programs. 
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E 

Elevation Source 
Selecting how contour altitude data will be entered. 

Entity 
An item that has a visual representation in the viewport. 

Exclude Boundary 
An area not used in the calculation of results. 

Existing Site Stage 
The site stage before any takeoff is carried out. 

Exported Volume 
The volume of material to be taken off site. 

F 

Fill 
The volume of material needed to be added to the site. 

Fill Volume 
The volume of material that has been added to the site from both reused and imported material. 

From Site Volume 
The volume of material re-used from site. 

G 

Global Material 
A central collection of all predefined default materials available to all projects. 

I 

Imported Fill Material 
The volume of material brought from off site for fill purposes. 

Imported Respread Material 
The volume of material brought from off site used for Respread. 
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Imported Volume 
The volume of material brought from off site for fill purposes and/or respread. 

Include Boundary 
An area used in the calculation of results. 

Increment 
Is the amount the contour altitude will increase/decrease by for the next contour entity. 

Item 
An Entity or Container in a list Pane. 

N 

Net Area 
Is the area of all the included areas with the excluded areas removed from it. 

O 

Operation Group 
Is the grouping of all like Strata Operations. Such that there may be multiple cuts that get grouped together. 

P 

Pane 
A component of the application designed to display the properties of the entity being worked on. 

PDF 
Portable Document Format. A file format created by Adobe used to transmit and display documents regardless of the 

software of the sender or receiver. It includes fonts, formatting, and graphics. 

Plan 
Is a drawing representation of a site stage.. 

Plan Layer 
Layers are the primary organizational tool used in Plans. Layers are the equivalent of the overlays used in paper-based 

drafting. 

Point 
A single coordinate within the viewport. 
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Polyline 
A continuous line composed of one or more line or arc segments used for takeoff. 

Project 
Represents the entirety of your work (Earthwork Calculations). 

Project Material 
All materials that have been used in the current project. 

Project Tab 
The button that is displayed in the top-left corner of the application. If you click the application button, the application 

menu is displayed. 

Proposed Site Stage 
The site stage after all takeoff is carried out. 

Q 

Quick Access Toolbar 
A Toolbar where you place common functionality likely to be used across different tabs. e.g. you might save the project 

while working on the home tab or while you are manipulating plans. 

R 

Raster File 
A file containing one or more raster images where the image is represented by pixels. 

Remainder 
Material that is left over after all Strata Operation has been completed and which no Strata Operation has altered. 

Respread 
Is putting a layer of soil over the top of an excavated site. 

Reused Volume 
The volume of excavated material from the site that has been reused 

Ribbon 
The horizontal area of the application window where a set of toolbars are placed on tabs 
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S 

Site 
Is a geographical location where work is planned to take place. 

Site Balance 
The difference between the material resued and the imported material expressed as a volume. 

Snap 
Is a help mode where if you are in a drawing mode e.g. spot or is polyline and the cursor is within a certain range of a 

point (any point, it may not be on an object) the input will snap to that point. 

Spot Elevation 
Is a point on a plan which has a altitude value. 

Stratum 
Is a ground layer of Rock or Soil with similiar characteristics distinguishing it from other layers. 

Stripping 
The volume of topsoil removed from the site for possible reuse. 

Stripping Reuse Percentage 
The percentage of stripped material that can  be reused as respread 

Structure 
Any man made entity that can appear in either existing or proposed site stage. 

Structure Boundary 
The perimeter of the structure (see "Structure"). 

Structure Material 
Any material below finish floor level that makes up the 3D structure entity. 

T 

Takeoff 
Takeoff is the entering of site entity data in the viewport for existing/proposed site stages. 

Toolbar 
A row of icons that represent related tools. Each icon, when clicked, invokes an action. 

Transmute 
A tool that can select a contour entity directly from a vector file. 
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V 

Vector File 
A file containing graphical data in vector form such as lines shapes, e.g. dwg,dxf. 

Viewport 
The graphical interface where you perform Take Off from Plans and view your 3D Site results. 

W 

Working Area 
The area in which work will be and won’t be carried out. 

Working Area Boundary 
A component that forms all or part of the working area. A working area can contain multiple Working Area Boundaries. 

X 

X Reference 
External reference attached to a vector file. 
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